Uprint Down

Minor incident Print & Copy Services
15-09-22 09:56 GMT · 3 hours, 25 minutes

Updates

Resolved

Resolved by Cantec

September 15, 2022 · 13:21 GMT
Issue

Students can upload jobs to their print queue but these jobs do not appear in the student’s queues at the printer.

September 15, 2022 · 09:57 GMT

← Back